Select Page

iOS 11 Upgrade Warning

Caution

Apple will soon be releasing iOS 11. The current version of the Transcendent application will not work on iOS 11.

Mintek is diligently making final revisions to a new version that will support iOS 11.

Notifications will be sent when it is safe to upgrade to this new version.

 

Caution

When the next version of Transcendent is released, the following devices can be upgraded to iOS 11.

Please DO NOT upgrade until you have received a notification from Mintek.

iOS 11 Compatible Devices

  • iPhone 5S & SE, 6, 6S, 6 Plus, 6s Plus, 7, 7 Plus
  • iPad: 5th generation
  • iPad miniĀ 2 and 4
  • iPad Air & 2
  • iPad Pro: 9.7 inch, 10.5 inch, 12.9 inch
  • iPod Touch: 6th generation